Задать вопрос
14 июля, 20:38

Помогите решить задачи по паскалю

1. Вычислить z (x) = sign (x) + sign (y) * sign (x+y)

Используя функцию

sign (x) = - 1 если x<0

0 если x=0

1 если x>0

2. Написать процедуру для нахождения степени числа и вычислить значение выражения:x^5+x^4+x^8

3. Составить программу получения изображения в котором в 1-ой строке будет изображена 1*, во 2-ой строке 2*, в 3-ей строке 3*, в строке с номером m-m*.

+4
Ответы (1)
  1. 15 июля, 00:34
    0
    1) var

    x:integer;

    begin

    readln (x) ;

    if x>0 then

    writeln (1)

    else if x<0 then

    writeln (-1)

    else

    writeln (0) ;

    end
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачи по паскалю 1. Вычислить z (x) = sign (x) + sign (y) * sign (x+y) Используя функцию sign (x) = - 1 если x0 2. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В математике функция sign (x) (знак числа) определена так: sign (x) = 1, если x > 0, sign (x) = - 1, если x < 0, sign (x) = 0, если x = 0. Для данного числа x выведите значение sign (x). Ввод 179 Вывод 1
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Ребят, помогите, ничего вообще не понимаю ... ((Что вообще за модуль, содержащий процедуру ... нужно написать программу) если можно с объяснениями) Написать модуль, содержащий процедуру нахождения минимальной цифры натурального числа.
Ответы (1)
Описать функцию Sign (X) целого типа, возвращающую для вещественного числа X следующие значения: 6 - 1, если X 0. С помощью этой функции найти значение выражения Sign (A) + Sign (B) для данных вещественных чисел A и B.
Ответы (1)
1. Составить программу для нахождения площади трапеции. 2. Составить программу для нахождения квадрата суммы двух чисел (по формулам сокращённого умножения). 3.
Ответы (1)