Задать вопрос
31 мая, 04:56

Ребят, помогите, ничего вообще не понимаю ... ((Что вообще за модуль, содержащий процедуру ... нужно написать программу) если можно с объяснениями)

Написать модуль, содержащий процедуру нахождения минимальной цифры натурального числа. Привести пример использования данного модуля. (в Паскале)

+2
Ответы (1)
  1. 31 мая, 07:32
    0
    Текст модуля (Free Pascal) :

    unit MyLib;

    interface

    procedure MinDigit (n:longint; var md:byte) ;

    implementation

    procedure MinDigit (n:longint; var md:byte) ;

    var

    d:byte;

    begin

    md:=10;

    while n>0 do begin

    d:=n mod 10;

    if d
    n:=n div 10

    end

    end;

    begin

    end.

    Тестовая программа:

    uses

    Crt, MyLib;

    var

    p:byte;

    begin

    ClrScr;

    MinDigit (45134, p) ;

    Writeln ('p=', p) ;

    ReadKey

    end.

    Тестовое решение:

    p=1
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ребят, помогите, ничего вообще не понимаю ... ((Что вообще за модуль, содержащий процедуру ... нужно написать программу) если можно с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Написать в Паскале процедуру с изменяемым параметром. помогите хотя бы с одним. Уровень A. Напишите процедуру, которая переставляет три переданные ей числа в порядке возрастания. Пример: Введите три натуральных числа: 10 15 5 5 10 15 Уровень B.
Ответы (1)
1) Составить функцию, которая определяет наибольшее из трех чисел и привести пример ее использования. Пример: Введите три числа: 28 15 10 Наибольшее число: 28 2) Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее
Ответы (1)
Даны два числа, если 1>2, то составить программу для нахождения среднего арефметического. Если 2>1, то для нахождения среднего геометрического. Можно в паскале
Ответы (1)
Pascal ABC. Написать процедуру, которая выводит на экран первые 3 элемента из массива, которые не равны друг другу. Или процедуру нахождения 3 максимальных элементов массива, которые не равны друг другу
Ответы (1)