Задать вопрос
14 мая, 19:36

Составьте программу позволяющую определить являются ли числа a, b, c пифагоровыми тройками.

+4
Ответы (1)
  1. 14 мая, 20:04
    0
    Var

    a, b, c: real;

    begin

    writeln ('Введите числа a, b, c') ;

    readln (a, b, c) ;

    if (sqr (a) = sqr (b) + sqr (c)) or (sqr (b) = sqr (a) + sqr (c)) or (sqr (c) = sqr (a) + sqr (b)) then

    writeln ('Данные числа являются пифагоровым тройками')

    else

    writeln ('Данные числа не являются пифагоровым тройками') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу позволяющую определить являются ли числа a, b, c пифагоровыми тройками. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
2 задачи по программированию: 1) Три точки заданы своими координатами (x1, y1), (x2, y2), (x3, y3). Напишите программу, позволяющую выяснить, какие из них находятся на максимальном расстоянии друг от друга, и вывести на печать значение этого
Ответы (1)
Написать программу для нахождения суммы цифр, составляющих число произвольной длины. Написать программу, позволяющую определить, сколько заданных символов в данной фразе (искомые символы и фраза вводятся с клавиатуры.
Ответы (1)
Составить программу, позволяющую по последней цифре данного числа определить последнюю цифру квадрата этого числа
Ответы (1)
Напишите программу, позволяющую по последней цифре трехзначного числа определить последнюю цифру его произведения на число 3 (например, для числа 234, последней цифрой при произведении на 3 будет цифра 2)
Ответы (1)
Создать программу позволяющую по последней цифре данного числа определить последнюю цифру куба этого числа
Ответы (1)