Задать вопрос
29 апреля, 17:12

Создать программу позволяющую по последней цифре данного числа определить последнюю цифру куба этого числа

+2
Ответы (1)
  1. 29 апреля, 18:27
    0
    Var

    n:integer;

    begin

    Write ('n=') ; Read (n) ;

    n:=Abs (n) ; { защита от злобных буратинок, любящих минусы }

    n:=n mod 10;

    n:=n*n*n mod 10;

    Writeln ('Последняя цифра куба этого числа равна ', n)

    end.

    Пример

    n=352421137

    Последняя цифра куба этого числа равна 3
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Создать программу позволяющую по последней цифре данного числа определить последнюю цифру куба этого числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль! Написать программу, в которой по последней цифре числа определить последнюю цифру его квадрата и последнюю цифру его куба. Для определения последней цифры числа применить операцию MOD (получение остатка от деления).
Ответы (1)
Напишите программу, позволяющую по последней цифре трехзначного числа определить последнюю цифру его произведения на число 3 (например, для числа 234, последней цифрой при произведении на 3 будет цифра 2)
Ответы (1)
Составить программу, позволяющую по последней цифре данного числа определить последнюю цифру квадрата этого числа
Ответы (1)
написать программу позволяющую по последней цифре числа определить последнюю цифру его квадрата
Ответы (1)
Дано целое положительное четырехзначное число. Напишите программу, позволяющую определить двузначное число, в котором число десятков соответствует первой цифре заданного числа, а число единиц-последней. Например: 3234 = > 34.
Ответы (1)