Задать вопрос
1 мая, 08:02

Написать программу для нахождения суммы цифр, составляющих число произвольной длины.

Написать программу, позволяющую определить, сколько заданных символов в данной фразе (искомые символы и фраза вводятся с клавиатуры. Например, сколько букв А и а в слове АбракАдабрА)

+2
Ответы (1)
  1. 1 мая, 11:19
    0
    Пункт а:

    Насколько я помню, в паскале невозможно реализовать бесконечный цикл, поэтому решение будет слегка притянуто за уши. Например если вы введете число из 9001 символа, программа будет работать неккоректно. Для выхода из цикла используется 'метка'.

    a, counter, Summa : integer;

    Label Transfer;

    Begin

    writeln ('Введите число') ;

    readln (a) ;

    counter : = 1;

    counterTw0 : = counterTwo + 1;

    while counter < 9000 Do

    begin

    counter : = counter + 1;

    if (a div counter) < 0 then Transfer

    else counterTwo : = counterTwo + 1;

    else;

    Goto Transfer;

    //Узнали, что в числе counterTwo символов

    while counter < counterTwo Do

    Summa : = Summa + ((a div counter) mod 10) ;

    Summa : = Summa + (a mod 10) ;

    writeln (Summa) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для нахождения суммы цифр, составляющих число произвольной длины. Написать программу, позволяющую определить, сколько ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)