Задать вопрос
29 февраля, 23:42

Составить программу для решения следующей задачи: Дан массив целых чисел, заполненный случайными числами в диапазоне [-100, 100]. Замените все отрицательные элементы максимальным. Выведите на экран исходный и измененный массивы.

+4
Ответы (1)
  1. 1 марта, 02:31
    0
    var

    i, max:integer;

    ar:array[0 ... 200] of integer;

    begin

    randomize;

    max:=0;

    for i:=1 to 200 do begin

    ar[i]:=random (200+1) - 100;

    if (ar[i] > max) then max:=ar[i];

    if (i mod 20=0) then writeln (ar[i]) else write (ar[i],' ') ;

    end;

    writeln () ;

    for i:=1 to 200 do begin

    if (ar[i] < 0) then ar[i]:=max;

    if (i mod 20=0) then writeln (ar[i]) else write (ar[i],' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу для решения следующей задачи: Дан массив целых чисел, заполненный случайными числами в диапазоне [-100, 100]. Замените ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
A) Составьте программу, которая заполняет масcив a[10 ... 20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Составьте программу, которая заполняет массив a[1 ... 10] случайными числами в диапазоне от 0 до 10, затем первый элемент меняет местами с максимальным элементом. Выведите на экран исходный и полученный массивы.
Ответы (1)