Задать вопрос
1 марта, 01:24

Программа на языке Pascal.

Компьютер в первую секунду печатает на экране число 1, во вторую - число 12, в третью - число 23. То есть, в каждую следующую секунду - на 11 больше, чем в предыдущую. В какую секунду впервые появится число, делящееся на 2009?

+1
Ответы (1)
  1. 1 марта, 03:21
    0
    program n1cel;

    var

    a, c:integer;

    begin

    a:=1;

    c:=1;

    while с mod 20090 do

    begin

    a:=a+1;

    c:=c+11;

    end;

    writeln ('через ', a, ' секунд') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа на языке Pascal. Компьютер в первую секунду печатает на экране число 1, во вторую - число 12, в третью - число 23. То есть, в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
На шахматной доске 64 клетки. На первую клетку кладут 1 зерно, на вторую-2 зерна, на третью - 3 зерна и т. д.: на каждую следующую клетку кладут на одно зерно больше, чем на предыдущую.
Ответы (1)
Составить, программа требует вести два числа если первое число больше второго то программа печатает слово больше если меньше второго то программа печатает слово меньше если оба числа равны то писать будет равно
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, делящееся нацело на 7. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)