Задать вопрос
6 ноября, 07:08

Составьте программу, которая заполняет массив a[1 ... 10] случайными числами в диапазоне от 0 до 10, затем первый элемент меняет местами с максимальным элементом. Выведите на экран исходный и полученный массивы.

+5
Ответы (1)
  1. 6 ноября, 08:08
    0
    Uses crt;

    const n=10;

    var a:array[1 ... n] of integer;

    i, max, k:integer;

    begin

    randomize;

    for i:=1 to n do

    begin

    a[i]:=random (10) ;

    write (a[i],' ') ;

    end;

    writeln;

    max:=-1;

    for i:=1 to n do

    if a[i]>max then begin max:=a[i]; k:=i; end;

    a[1]:=a[1]+a[k];

    a[k]:=a[1]-a[k];

    a[1]:=a[1]-a[k];

    for i:=1 to n do

    write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая заполняет массив a[1 ... 10] случайными числами в диапазоне от 0 до 10, затем первый элемент меняет местами с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
A) Составьте программу, которая заполняет масcив a[10 ... 20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Составьте программу, которая заполняет массив [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)
составьте программу которая заполняет массив а (1 ... 10) случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый элемент со вторым, третий с четвертым, и т. д. выведите исходный и полученный массивы
Ответы (1)
Составьте программу, которая выполняет массив а (1 ... 10) случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый элемент со вторым, третий с четвертым и т. д. Выведите на экран исходный и полученный массивы.
Ответы (1)