Задать вопрос
27 ноября, 13:29

Составьте программу, которая выполняет массив а (1 ... 10) случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый элемент со вторым, третий с четвертым и т. д.

Выведите на экран исходный и полученный массивы.

+2
Ответы (1)
  1. 27 ноября, 15:06
    0
    Program swap;

    const

    N = 10;

    var

    a: array [1 ... N] of integer;

    i, temp: integer;

    begin

    randomize;

    writeln ('исходный массив: ') ;

    for i : = 1 to N do

    begin

    a[i] : = Random (10) ;

    write (a[i], ' ') ;

    end;

    writeln;

    i : = 1;

    while i < = 9 do

    begin

    temp : = a[i];

    a[i] : = a[i+1];

    a[i+1] : = temp;

    i : = i + 2;

    end;

    writeln ('полученный массив: ') ;

    for i : = 1 to N do

    write (a[i], ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая выполняет массив а (1 ... 10) случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
A) Составьте программу, которая заполняет масcив a[10 ... 20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)
составьте программу которая заполняет массив а (1 ... 10) случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый элемент со вторым, третий с четвертым, и т. д. выведите исходный и полученный массивы
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Составьте программу, которая заполняет массив [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)