Задать вопрос
18 июня, 06:45

1). Дан миссив из n целых чисел. Напишите программу определяющую сколько в массиве четных чисел,

2). Дан массив из n целых чисел. Напишите программу определяющую каких элементов в точке больше положительных или отрицательных

+2
Ответы (1)
  1. 18 июня, 07:08
    0
    Program BiFi;

    Const n=50;

    Var A:array[1 ... n] of integer;

    i, c, l:integer;

    Begin

    for i:=1 to n do readln (A[i]) ;

    c:=0;

    for i:=1 to n do if A[i] mod 2 = 0 then c:=c+1;

    writeln (c) ;

    readln;

    end.

    Program BiFi;

    Const n=50;

    Var A:array[1 ... n] of integer;

    i, k, l:integer;

    Begin

    k:=0;

    l:=0;

    for i:=1 to n do begin readln (a[i]) ;

    if A[i]<0 then k:=k+1

    else if A[i]>0 then l:=l+1;

    end;

    if k>l then writeln ('больше положительных')

    else if l>k then writeln ('больше отрицательных')

    else writeln ('одинаково') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1). Дан миссив из n целых чисел. Напишите программу определяющую сколько в массиве четных чисел, 2). Дан массив из n целых чисел. Напишите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)