Задать вопрос
18 июня, 06:41

Используя процедуру для вычисления степени числа, найти значение выражения:

у = а4x^4 + а3 х^3 + a2 х^2 + a1 х + a0.

Коэффициенты а4, а3 а2, а1, а0 и х вводятся с клавиатуры.

+3
Ответы (1)
  1. 18 июня, 07:21
    0
    Pascal:

    function power (a: integer; n: integer) : integer;

    begin

    if n = 0 then

    power : = 1

    else if n mod 2 = 0 then

    power : = sqr (power (a, n div 2))

    else

    power : = power (a, n - 1) * a;

    end;

    var

    a: array[0 ... 4] of integer;

    x, i, res: integer;

    begin

    res : = 0;

    for i : = 4 downto 0 do

    read (a[i]) ;

    readln (x) ;

    for i : = 4 downto 0 do

    inc (res, a[i] * power (x, i)) ;

    writeln (res)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Используя процедуру для вычисления степени числа, найти значение выражения: у = а4x^4 + а3 х^3 + a2 х^2 + a1 х + a0. Коэффициенты а4, а3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
1 Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров , в каком из двух введенных с клавиатуры целых чисел произведение цифр больше.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)