Задать вопрос
3 сентября, 23:11

1

Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров

, в каком из двух введенных с клавиатуры целых чисел произведение цифр больше. Для подсчета произведения цифр использовать процедуру.

2

Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров

+1
Ответы (1)
  1. 4 сентября, 02:44
    0
    1) Тут в смысле надо тебе интеграл найти? если да, то

    Program Pr2;

    uses crt;

    procedure arifm (a, b:integer; var s:real) ;

    begin

    s: = (a+b) / 2;

    end;

    procedure proiz (var a, b, c:integer) ;

    var i, m1, m2:integer;

    begin

    m1:=1; m2:=1;

    for i:=1 to a do m1:=m1*i;

    for i:=1 to b do m2:=m2*i;

    if m1>m2 then c:=m1

    else c:=m2;

    end;

    var a, b, c:integer;

    s:real;

    Begin

    clrscr;

    readln (a, b) ;

    arifm (a, b, s) ;

    writeln (s) ;

    proiz (a, b, c) ;

    writeln (c) ;

    end.

    2)

    Program Pr1;

    uses crt;

    procedure arifm (var a, b:integer; s:real) ;

    begin

    s: = (a+b) / 2;

    writeln (s:8:3) ;

    end;

    var a, b:integer;

    s:real;

    Begin

    clrscr;

    readln (a, b) ;

    arifm (a, b, s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1 Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров , в каком из двух ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
Напишите программу подсчета суммы и произведения цифр для данного целого двузначного числа. Используйте пригласительную строку. Используйте процедуру очистки экрана (для ТП).
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
С++. Дана целая матрица А (N, M). Составить программу подсчета среднего арифметического значения матрицы. Найти отклонение от среднего у элементов каждой строки.
Ответы (1)
Составить процедуру определения среднего арифметического значения элементов одномерного массива А[m]. Используя процедуру, определить среднее арифметическое побочной диагонали квадратной матрицы B[m, m].
Ответы (1)