Задать вопрос
22 июля, 21:56

Напишите программу подсчета суммы и произведения цифр для данного целого двузначного числа. Используйте пригласительную строку. Используйте процедуру очистки экрана (для ТП). Установите формат вывода данных: 6 позиций для всего числа, 2 позиции - для доробной части.

Дополнительно: напишите программу, которая меняет местами цифры в целом двузначном числе. Например:

Входные данные: 35

Результат: 53

+3
Ответы (1)
  1. 22 июля, 22:42
    0
    1)

    uses crt;

    var chislo, summa, proiz:integer;

    begin

    clrscr;

    Readln (chislo) ;

    summa: = (chislo div 10) + (chislo mod 10) ;

    proiz: = (chislo div 10) * (chislo mod 10) ;

    Writeln (' сумма:', summa:6:2) ;

    Writeln (' произведения : ', proiz:6:2) ;

    end.

    2)

    var chislo:integer;

    begin

    Readln (chislo) ;

    chislo: = (chislo div 10) + (chislo mod 10) * 10;

    Writeln (chislo) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу подсчета суммы и произведения цифр для данного целого двузначного числа. Используйте пригласительную строку. Используйте ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код. Используйте процедуру входные данные 5 выходные данные 101 входные данные -14 выходные данные -1110
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)