Задать вопрос
29 апреля, 00:38

Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код. Используйте процедуру

входные данные

5

выходные данные

101

входные данные

-14

выходные данные

-1110

+4
Ответы (1)
  1. 29 апреля, 01:58
    0
    Procedure Dec2Bin (n: longint; var s: string) ;

    var

    z: string;

    d: char;

    begin

    s : = '';

    if n < 0 then z : = '-' else z : = '';

    n : = abs (n) ;

    while n > 0 do

    begin

    if (n mod 2) = 0 then d : = '0' else d : = '1';

    s : = d + s;

    n : = n div 2

    end;

    s : = z + s;

    if s = '' then s : = '0'

    end;

    var

    n: longint;

    s: string;

    begin

    Write ('Введите целое число: ') ; Readln (n) ;

    Dec2Bin (n, s) ;

    Writeln (s)

    end.

    Тестовое решение:

    Введите целое число: - 14

    -1110
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код. Используйте процедуру входные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)