Задать вопрос
6 июня, 18:12

Написать программу для паскаля. Дан массив x размера n (n=10) целых

чисел, содержащий как положительные, так и отрицательные элементы. Упорядочить

массив следующим образом: сначала идут отрицательные числа, упорядоченные по

невозрастанию, потом положительные, упорядоченные по неубыванию.

+2
Ответы (1)
  1. 6 июня, 19:10
    0
    Program gt;

    var A, B, C:array[1 ... 1000]of longint;

    p, l, n, i, j, k, w:longint;

    begin

    n:=10;

    for i:=1 to n do

    read (A[i]) ;

    k:=0; w:=0;

    for i:=1 to n do

    begin

    if (A[i]<0) then begin

    k:=k+1; b[k]:=a[i];

    end;

    if (A[i]>0) then begin

    w:=w+1;

    c[w]:=a[i];

    end;

    end;

    for i:=1 to k-1 do

    for j:=1 to k-i do

    begin

    p:=b[j]; l:=b[j+1];

    if b[j]
    b[j]:=l; b[j+1]:=p;

    end;

    end;

    for i:=1 to k do

    write (b[i],' ') ;

    for i:=1 to w do

    write (c[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для паскаля. Дан массив x размера n (n=10) целых чисел, содержащий как положительные, так и отрицательные элементы. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
H. Работа с несколькими массивами Дан массив a, состоящий из n целых чисел. Ваша задача - переписать его элементы в другой массив такого же размера следующим образом: сначала должны идти все отрицательные элементы, а затем все остальные.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Дан массив, состоящий из целых чисел. Известно, что числа упорядочены по неубыванию (то есть каждый следующий элемент не меньше предыдущего). Напишите программу, которая определит количество различных чисел в этом массиве.
Ответы (1)
Написать програму для Паскаля: Дан линейный массив, содержащий положительные и отрицательные целые числа, n=10.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)