Задать вопрос
9 ноября, 01:06

Написать програму для Паскаля: Дан линейный массив, содержащий положительные и отрицательные целые числа, n=10. Создать новый массив, в котором содержатся только положительные элементы из исходного масива, упорядочить этот новый массив по возрастанию.

+3
Ответы (1)
  1. 9 ноября, 02:58
    0
    var

    i, j, k, p: integer;

    a, b: array[1 ... 10] of integer;

    begin

    k : = 0;

    for i : = 1 to 10 do

    begin

    a[i] : = random (20) - 10;

    write (a[i]:3) ;

    if a[i] > 0 then

    begin

    k : = k + 1;

    b[k] : = a[i];

    end;

    end;

    for i : = 1 to k - 1 do

    for j : = i + 1 to k do

    if b[i] > b[j] then

    begin

    p : = b[i];

    b[i] : = b[j];

    b[j] : = p;

    end;

    writeln;

    for i : = 1 to k do write (b[i]:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать програму для Паскаля: Дан линейный массив, содержащий положительные и отрицательные целые числа, n=10. Создать новый массив, в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Написать программу для паскаля. Дан массив x размера n (n=10) целых чисел, содержащий как положительные, так и отрицательные элементы.
Ответы (1)
Дан массив b (n). Переписать в массив C (n) отрицательные элементы массива b (n) умноженные на 4. Затем упорядочить методом "пузырька" по возрастанию новый массив. Найти общее количество одинаковых элементов в упорядоченном массиве.
Ответы (1)
Дан массив х (n). Переписать в массив y (n) отрицательные элементы массива х умноженные на 2. (со сжатием., без пустых элементов внутри) Затем упорядочить методом "выбора и перестановки"по возрастанию новый массив.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)