Задать вопрос
1 сентября, 03:20

Дан

массив b (n). Переписать в массив C (n)

отрицательные элементы массива b (n)

умноженные на 4. Затем упорядочить методом "пузырька" по

возрастанию новый массив. Найти общее

количество одинаковых элементов в упорядоченном массиве.

+2
Ответы (1)
  1. 1 сентября, 06:40
    0
    Const n=5; m=4;

    var b, c:array[1 ... n] of real; k, i:integer; t:boolean;

    begin

    for i:=1 to n do read (b[i]) ;

    for i:=1 to n do if b[i]<0 then c[i]:=b[i]*m;

    t:=true;

    while t do begin

    t:=false;

    for i:=1 to n-1 do if c[i]>c[i+1] then begin

    t:=true;

    c[i]:=c[i]+c[i+1]; c[i+1]:=c[i]-c[i+1]; c[i]:=c[i]-c[i+1]

    end

    end;

    for i:=1 to n do if c[i]<0 then write (c[i],' ') else break;

    writeln;

    k:=0;

    for i:=1 to n-1 do begin

    if c[i]=0 then break;

    if c[i]=c[i+1] then begin

    if t=false then begin t:=true; k:=k+1 end;

    k:=k+1; end

    else t:=false

    end;

    write (k)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив b (n). Переписать в массив C (n) отрицательные элементы массива b (n) умноженные на 4. Затем упорядочить методом "пузырька" по ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дан массив х (n). Переписать в массив y (n) элементы массива х, большие 3. Затем упорядочить методом "пузырька" по возрастанию новый массив. Выдать на экран номера одинаковых элементов в упорядоченном массиве.
Ответы (1)
Дан массив х (n). Переписать в массив y (n) отрицательные элементы массива х умноженные на 2. (со сжатием., без пустых элементов внутри) Затем упорядочить методом "выбора и перестановки"по возрастанию новый массив.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)