Задать вопрос
23 октября, 13:57

1. Дан массив х (n). Переписать в массив y (n) элементы массива х, большие 3. Затем

упорядочить методом "пузырька" по возрастанию

новый массив. Выдать на экран номера одинаковых элементов в

упорядоченном массиве.

+3
Ответы (1)
  1. 23 октября, 14:40
    0
    Const n=5; m=3;

    var x, y:array[1 ... n] of real; i:integer; t:boolean;

    begin

    for i:=1 to n do read (x[i]) ;

    for i:=1 to n do if x[i]>m then y[i]:=x[i];

    t:=true;

    while t do begin

    t:=false;

    for i:=1 to n-1 do if ((y[i]y[i+1])) and (y[i+1]>m) then begin

    t:=true;

    y[i]:=y[i]+y[i+1]; y[i+1]:=y[i]-y[i+1]; y[i]:=y[i]-y[i+1]

    end

    end;

    for i:=1 to n do if y[i]>m then write (y[i],' ') else break;

    writeln;

    for i:=1 to n-1 do begin

    if y[i]<=m then break;

    if y[i]=y[i+1] then begin

    if t=false then begin t:=true; write (i,' ') end;

    write (i+1,' ') end

    else t:=false

    end

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дан массив х (n). Переписать в массив y (n) элементы массива х, большие 3. Затем упорядочить методом "пузырька" по возрастанию новый ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив b (n). Переписать в массив C (n) отрицательные элементы массива b (n) умноженные на 4. Затем упорядочить методом "пузырька" по возрастанию новый массив. Найти общее количество одинаковых элементов в упорядоченном массиве.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Дан массив х (n). Переписать в массив y (n) отрицательные элементы массива х умноженные на 2. (со сжатием., без пустых элементов внутри) Затем упорядочить методом "выбора и перестановки"по возрастанию новый массив.
Ответы (1)