Задать вопрос
19 декабря, 20:24

Дан массив, состоящий из целых чисел. Известно, что числа упорядочены по неубыванию (то есть каждый следующий элемент не меньше предыдущего). Напишите программу, которая определит количество различных чисел в этом массиве.

Входные данные

Сначала задано число N - количество элементов в массиве (1N100). Далее через пробел записаны N чисел - элементы массива. Массив состоит из целых чисел.

Выходные данные

Необходимо вывести единственное число - количество различных чисел в массиве.

Примеры

Входные данные

5

1 1 1 1 1

Выходные данные

1

+3
Ответы (1)
  1. 20 декабря, 00:14
    0
    Program X;

    var

    mas: array[1 ... 1000000] of longint;

    N, i, count:longint;

    begin

    count:=1;

    readln (N) ;

    for i:=1 to N do

    read (mas[i]) ;

    if N>1 then

    begin

    for i:=2 to N do

    if mas[i]mas[i-1] then inc (count) ;

    writeln (count)

    end

    else

    writeln (1)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив, состоящий из целых чисел. Известно, что числа упорядочены по неубыванию (то есть каждый следующий элемент не меньше ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками. Входные данные Сначала задано число N - количество элементов в массиве (1N10000).
Ответы (1)
Вводится массив, состоящий из целых чисел. Найти наибольшее среди них. Входные данные Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива. Массив состоит из целых чисел.
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данных Сначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)