Задать вопрос
19 февраля, 05:43

Составить программу (Turbo Pascal) вычисления величины дохода по вкладу. Процентная ставка (в процентах годовых) и время хранения (в днях) задаются во время работы программы. Ниже представлен рекомендуемый вид диалога во время работы программы. Данные, вводимые пользователем, выделены жирным шрифтом.

Величина вклада (р.) - 25000

Срок вклада (дней) - 30

Годовая процентная ставка (%) - 12

Доход: 252 р. 80 коп.

Сумма по окончании срока вклада: 25252 р. 80 коп.

+5
Ответы (2)
  1. 19 февраля, 06:28
    0
    Я не экономист и не экстрасенс, так что если именно сама формула подсчета дохода неверна - меняйте сами, я ее просто нашла в интернете.

    var

    vklad, dohod, summa, stavka: real;

    srok: integer;

    begin

    write ('Величина вклада (р.) - ') ;

    readln (vklad) ;

    write ('Срок вклада (дней) - ') ;

    readln (srok) ;

    write ('Годовая процентная ставка (%) - ') ;

    readln (stavka) ;

    dohod : = (vklad*stavka) / (100*365) * srok;

    summa : = vklad + dohod;

    writeln ('Доход: ', Trunc (dohod), ' р.', frac (dohod) * 100:3:0, ' коп.') ;

    writeln ('Сумма по окончании срока вклада: ', Trunc (summa), ' р.', Frac (summa) * 100:3:0, ' коп.') ;

    end.
  2. 19 февраля, 07:24
    0
    {pascal, консольный ввод}

    var

    velichina_vklada, srok_vklada, godovaya_procentnaya_stavka: integer;

    vklad_s_procentami: real;

    vklad_s_procentami_rub, vklad_s_procentami_kop: integer;

    dohod_rub, dohod_kop: integer;

    begin

    write ('Величина вклада (р.) - ') ;

    readln () ;

    write ('Срок вклада (дней) - ') ;

    readln (srok_vklada) ;

    write ('Годовая процентная ставка (%) - ') ;

    readln (godovaya_procentnaya_stavka) ;

    vklad_s_procentami : = velichina_vklada * ((real (100) + real (godovaya_procentnaya_stavka) * real (srok_vklada) / 365) / 100) ;

    dohod_rub : = (velichina_vklada - integer (vklad_s_procentami)) ;

    dohod_kop : = (velichina_vklada*100 - integer (vklad_s_procentami*100)) mod 100;

    vklad_s_procentami_rub : = integer (vklad_s_procentami) ;

    vklad_s_procentami_kop : = integer ((vklad_s_procentami*100)) mod 100;

    writeln ('Доход: ', dohod_rub,' р. ', dohod_kop, ' 80 коп.') ;

    writeln ('Сумма по окончании срока вклада: ', vklad_s_procentami_rub, ' р. ', vklad_s_procentami_kop, ' коп.') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу (Turbo Pascal) вычисления величины дохода по вкладу. Процентная ставка (в процентах годовых) и время хранения (в днях) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составить программу, отгадывающую натуральное четное число, загаданное пользователем. Ниже представлен рекомендуемый вариант диалога во время работы программы (жирным шрифтом выделены данные, вводимые пользователем).
Ответы (1)
Turbo Pascal Написать программу вычисления объема цилиндра. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). Вычисление объема цилиндра.
Ответы (1)
2. Составить программу для нахождения цифр четырехзначного числа. Ниже представлен пример диалога. Данные, вводимые пользователем, выделены жирным шрифтом.
Ответы (1)
Создать программу вычисления доходов по вкладу. Исходным данным является 1) величина вклада 2) срок вклада 3) процентная вставка Исходные данные вводятся с клавиатуры.
Ответы (1)
Написать программу вычисления расстояния между населенными пунктами, изображенными на карте. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).
Ответы (1)