Задать вопрос
4 марта, 12:48

2. Составить программу для нахождения цифр четырехзначного числа. Ниже представлен пример диалога. Данные, вводимые пользователем, выделены жирным шрифтом. Введите четырехзначное число 3281 Число тысяч равно 3 Число сотен равно 2 Число десятков равно 8 Число единиц равно 1

+3
Ответы (1)
  1. 4 марта, 16:00
    0
    Program pr;

    uses crt;

    Var a, x1, x2, x3, x4:integer;

    Begin

    Writeln ('введите 4-х значное число') ;

    readln (a) ;

    x1:=a div 1000;

    x2: = (a mod 1000) div 100;

    x3: = (a mod 100) div 10;

    x4:=a mod 10;

    Writeln (x1) ;

    Writeln (x2) ;

    Writeln (x3) ;

    Writeln (x4) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «2. Составить программу для нахождения цифр четырехзначного числа. Ниже представлен пример диалога. Данные, вводимые пользователем, выделены ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составить программу, отгадывающую натуральное четное число, загаданное пользователем. Ниже представлен рекомендуемый вариант диалога во время работы программы (жирным шрифтом выделены данные, вводимые пользователем).
Ответы (1)
2) Вводится четырехзначное число с клавиатуры. Определить цифру тысяч, сотен, десятков и единиц. В окне вывода должно быть так (это пример) Введи четырехзначное число: 1234 цифра тысяч-1 цифра сотен-2 цифра десятков-3 цифра единиц - 4
Ответы (1)
Вводится четырехзначное число с клавиатуры. Определить цифру тысяч, сотен, десятков и единиц. В окне вывода должно быть так (это пример) Введи четырехзначное число: 1234 цифра тысяч-1 цифра сотен-2 цифра десятков-3 цифра единиц - 4
Ответы (1)
Составить программу (Turbo Pascal) вычисления величины дохода по вкладу. Процентная ставка (в процентах годовых) и время хранения (в днях) задаются во время работы программы. Ниже представлен рекомендуемый вид диалога во время работы программы.
Ответы (2)
Turbo Pascal Написать программу вычисления объема цилиндра. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). Вычисление объема цилиндра.
Ответы (1)