Задать вопрос
2 сентября, 12:51

дана матрица 5 на 5, надо сделать такую программу которая с каждой строки

будет выводить максимальное число.

типо ложно так выглядеть

2 3 4 5 6

4 6 3 2 4

5 6 7 8 3

2 5 3 4 6

3 4 5 9 0

первая строка 6

второая 6

третья 8

четвертая 6

пятая 9

+4
Ответы (1)
  1. 2 сентября, 14:20
    0
    Var a:array [1 ... 5, 1 ... 5] of integer; i, j, max:integer;

    begin

    max:=0;

    for i:=1 to 5 do

    for j:=1 to 5 do

    readln (a[i, j]) ;

    for i:=1 to 5 do begin

    for j:=1 to 5 do

    if a[i, j]>max then max:=a[i, j];

    writeln (t,' = ', max) ; inc (t) ; max:=0; end;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дана матрица 5 на 5, надо сделать такую программу которая с каждой строки будет выводить максимальное число. типо ложно так выглядеть 2 3 4 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
На паскале Даны две строки. Определите, является ли первая строка подстрокой второй строки. Входные данные На вход подается 2 строки длины не более 10000, состоящие только из маленьких букв латинского алфавита.
Ответы (2)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Дана строка, содержащая два слова, разделенные знаком нижнее подчеркивание. Написать программу заменяющую нижнее подчеркивание на запятую и вставляющую после запятой пробел. Дана строка, содержащая пробел.
Ответы (1)