Задать вопрос
14 декабря, 21:03

Дана строка, содержащая два слова, разделенные знаком нижнее подчеркивание. Написать программу заменяющую нижнее подчеркивание на запятую и вставляющую после запятой пробел.

Дана строка, содержащая пробел. Написать программу, меняющую местами части строки до и после пробела и добавляющую в конец строки вопросительный знак.

+3
Ответы (1)
  1. 14 декабря, 23:28
    0
    1.

    var s:string; p:integer;

    begin

    readln (s) ;

    p:=pos ('_', s) ;

    delete (s, p, 1) ;

    insert (', ', s, p) ;

    writeln (s) ;

    end.

    Пример:

    program_begin

    program, begin

    2.

    var s:string; l, p:integer;

    begin

    readln (s) ;

    l:=length (s) ;

    p:=pos (' ', s) ;

    s:=copy (s, p+1, l-p+1) + ' '+copy (s, 1, p-1) + '?';

    writeln (s) ;

    end.

    Пример:

    program begin

    begin program?
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана строка, содержащая два слова, разделенные знаком нижнее подчеркивание. Написать программу заменяющую нижнее подчеркивание на запятую и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана строка, содержащая слова, разделенные одним или несколькими пробелами. Написать программу, заменяющую каждый пробел символом"?"
Ответы (1)
Программа: pascal abc. Задание: дана строка, написать программу, вставляющую после каждой точки символ пробела.
Ответы (1)
Мальвина решила научить Буратино писать предложения и ставить знаки препинания: точку, запятую, восклицательный и вопросительный знак. За первый месяц Мальвина сможет научить Буратино писать предложения.
Ответы (1)
Дан текст, содержащий запятые. Написать программу, вставляющую после каждой запятой пробел.
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)