Задать вопрос
26 ноября, 18:44

Дан текст, содержащий запятые. Написать программу, вставляющую после каждой запятой пробел.

+4
Ответы (1)
  1. 26 ноября, 20:56
    0
    Var

    s : string;

    i : integer;

    begin

    readln (s) ;

    i : = 1;

    while (i < = length (s)) do

    begin

    if (s[i] = ',') then insert (' ', s, i + 1) ;

    i : = i + 1;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан текст, содержащий запятые. Написать программу, вставляющую после каждой запятой пробел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана строка, содержащая два слова, разделенные знаком нижнее подчеркивание. Написать программу заменяющую нижнее подчеркивание на запятую и вставляющую после запятой пробел. Дана строка, содержащая пробел.
Ответы (1)
Дан текст. Написать программу, вставляющую после каждой запятой по одному пробелу.
Ответы (1)
Пробел ... 1) ставится перед запятой, двоеточием; 2) не ставится перед запятой, двоеточием; 3) ставится перед запятой, двоеточием и за запятой, двоеточием
Ответы (1)
Программа: pascal abc. Задание: дана строка, написать программу, вставляющую после каждой точки символ пробела.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)