Задать вопрос
16 января, 02:33

Дан текст. Написать программу, вставляющую после каждой запятой по одному пробелу.

+5
Ответы (1)
  1. 16 января, 05:59
    0
    Read (s) ;

    i:=1;

    while i
    begin

    if s (i) = ',' then / / возможно нужны []

    insert (' ', s, i+1) ;

    i:=i+1;

    end;

    write (s) ;

    Проверить работу сейчас не могу, но вроде все норм))
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан текст. Написать программу, вставляющую после каждой запятой по одному пробелу. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан текст, содержащий запятые. Написать программу, вставляющую после каждой запятой пробел.
Ответы (1)
Дана строка, содержащая два слова, разделенные знаком нижнее подчеркивание. Написать программу заменяющую нижнее подчеркивание на запятую и вставляющую после запятой пробел. Дана строка, содержащая пробел.
Ответы (1)
Составьте программу, которая удаляет лишние пробелы в строке s, оставляя по одному пробелу между словами. Строка s, состоящая из слов, разделенных пробелами, вводится с клавиатуры.
Ответы (1)
Программа: pascal abc. Задание: дана строка, написать программу, вставляющую после каждой точки символ пробела.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)