Задать вопрос
5 июля, 16:04

Составьте программу, которая удаляет лишние пробелы в строке s, оставляя по одному пробелу между словами. Строка s, состоящая из слов, разделенных пробелами, вводится с клавиатуры.

+3
Ответы (1)
  1. 5 июля, 16:15
    0
    Uses System;

    uses System. Linq; var s: array of string;

    a: string;

    i, x: integer; begin

    readln (a) ;

    s : = a. Split () ;

    for i : = 0 to s. Length - 1 do

    if (s[i]. Length 0) then

    write (s[i] + ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая удаляет лишние пробелы в строке s, оставляя по одному пробелу между словами. Строка s, состоящая из слов, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая удаляет первое слово строки s. Строка s, состоящая из двух слов, разделенных пробелами, вводиться с клавиатуры.
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)
Дана строка S, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в S ровно один раз. Формат входных данных Во входном файле дана строка S.
Ответы (1)
С клавиатуры вводится строка со словами, разделёнными пробелами (к примеру "йогурт банан ананас"). Необходимо отстортировать слова в этой строке по алфавиту (чтобы конечная строка получилась "ананас банан йогурт").
Ответы (1)
Написать программу на Python: 1. Использовать для решения задачи count. Дана строка, состоящая из слов, которые разделенны пробелами. Определить, сколько в ней слов. 2. Дана строка. Заменить в этой строке все буквы h на букву H.
Ответы (2)