Задать вопрос
17 октября, 05:05

Дана строка S, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в S ровно один раз. Формат входных данных Во входном файле дана строка S. Строка S состоит из строчных букв латинского алфавита и пробелов; в ней есть хотя бы одна буква, ёe длина не превышает 100 символов. Формат выходных данных Выведите все слова, которые встречаются в S ровно один раз. Каждое слово выводите на новой строке в том порядке, в котором они встречаются в S. Примеры: Вход to be or not to be Выход or not.

UPD. На Free Pascal надо

+1
Ответы (1)
  1. 17 октября, 06:02
    0
    var s, s1, s2:string;

    p, k:integer;

    begin

    writeln ('Введите строку:') ;

    readln (s) ;

    s1:=s+' ';

    while pos (' ', s1) >0 do delete (s1, pos (' ', s1),1) ;

    while s1'' do

    begin

    p:=pos (' ', s1) ;

    s2:=copy (s1,1, p-1) ;

    delete (s1,1, p) ;

    k:=1;

    while pos (s2, s1) >0 do

    begin

    k:=k+1;

    delete (s1, pos (s2, s1), p) ;

    end;

    if k=1 then writeln (s2) ;

    end;

    end.

    Пример:

    Введите строку:

    to be or not to be

    or

    not
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана строка S, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в S ровно один раз. Формат входных данных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)
Задача по программированию на Паскаль, нужна помощь. Дана строка состоящая из строчных букв английского алфавита. Необходимо определить какие буквы встречаются в этой строке больше одного раза.
Ответы (1)
Вам дана строка S. Надо определить, сколько в ней цифр Формат входных данных Единственная строка входного файла содержит строку S, которая может состоять из букв английского алфавита и цифр.
Ответы (2)
С некоторого момента прошло N дней. Сколько полных недель прошло за этот период. Формат входных данных На вход программе подается 0≤N≤106. Формат выходных данных Вывести целое число - ответ на вопрос. Примеры: Вход 100 Выход 14
Ответы (1)
Задача F Четный палиндром Подстрокой строки называется любая непустая последовательность символов в строке. Палиндромом называется строка, которая читается одинаково слева и справа. У Азизхана есть строка S.
Ответы (1)