Задать вопрос
21 мая, 04:13

Вам дана строка S. Надо определить, сколько в ней цифр

Формат входных данных

Единственная строка входного файла содержит строку S, которая может состоять из букв английского алфавита и цифр.

Гарантируется, что строка не пустая и ее длина не превосходит 100

Формат выходных данных

Выведите ответ к задаче

+5
Ответы (2)
  1. 21 мая, 04:20
    0
    Program Task;

    Var S: String;

    i, nums: Integer;

    Begin

    WriteLn ('Введите строку') ;

    ReadLn (S) ;

    If Length (S) > 100 Then

    WriteLn ('Ошибка. Завершение работы программы') ;

    For i : = 1 To Length (S) Do

    If (Ord (S[i]) > = 48) And (Ord (S[i]) < = 57) Then

    nums : = nums + 1;

    WriteLn ('Количество цифр в строке: ', nums) ;

    ReadLn;

    End.
  2. 21 мая, 04:57
    0
    Var

    s: string;

    k, i: integer;

    begin

    read (s) ;

    for i : = 1 to length (s) do

    if (s[i] in ['0' ... '9']) then

    k : = K + 1;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вам дана строка S. Надо определить, сколько в ней цифр Формат входных данных Единственная строка входного файла содержит строку S, которая ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача C. Делители Дано целое число N. Вам нужно определить количество его делителей Формат входных данных Единственная строка входного файла содержит целое число N (1 < = N < = 10^12) Формат выходных данных Выведите ответ к задаче
Ответы (1)
задается целое число N. нужно вывести количество четных делителей числа N. Формат входных данных Единственная строка входного файла содержит единственное целое число N (1
Ответы (1)
Задача A Дана последовательность чисел А длины N. Требуется вывести в обратном порядке. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 1000000) - длину последовательности.
Ответы (1)
Задача D Нечет Задано два целых числа A и B. Найдите сумму нечетных чисел от A до B. Формат входных данных Первая строка входного файла содержит два целых числа A и B (1 < = A, B < = 10^9). Формат выходных данных Выведите ответ к задаче.
Ответы (1)
Задача F Четный палиндром Подстрокой строки называется любая непустая последовательность символов в строке. Палиндромом называется строка, которая читается одинаково слева и справа. У Азизхана есть строка S.
Ответы (1)