Задать вопрос
5 февраля, 02:15

Задача C. Делители Дано целое число N. Вам нужно определить количество его делителей Формат входных данных Единственная строка входного файла содержит целое число N (1 < = N < = 10^12) Формат выходных данных Выведите ответ к задаче

+5
Ответы (1)
  1. 5 февраля, 03:34
    0
    var

    n, i:integer;

    begin

    readln (n) ;

    for i:=1 to n do

    if n mod i = 0 then

    write (i,' ') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача C. Делители Дано целое число N. Вам нужно определить количество его делителей Формат входных данных Единственная строка входного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
задается целое число N. нужно вывести количество четных делителей числа N. Формат входных данных Единственная строка входного файла содержит единственное целое число N (1
Ответы (1)
Вам дана строка S. Надо определить, сколько в ней цифр Формат входных данных Единственная строка входного файла содержит строку S, которая может состоять из букв английского алфавита и цифр.
Ответы (2)
Задача A Дана последовательность чисел А длины N. Требуется вывести в обратном порядке. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 1000000) - длину последовательности.
Ответы (1)
Задача D Нечет Задано два целых числа A и B. Найдите сумму нечетных чисел от A до B. Формат входных данных Первая строка входного файла содержит два целых числа A и B (1 < = A, B < = 10^9). Формат выходных данных Выведите ответ к задаче.
Ответы (1)
Дается последовательность из N чисел. Выведите разницу между максимальным и минимальным элементами последовательности. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 100000).
Ответы (1)