Задать вопрос
14 апреля, 20:39

Дается последовательность из N чисел. Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных

Первая строка входного файла содержит целое число N (1 < = N < = 100000). В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.

Формат выходных данных

Выведите ответ к задаче.

+2
Ответы (1)
  1. 14 апреля, 21:34
    0
    Const n=4; { любое число N от 1 до 100000} var a:array [1 ... n] of integer; b, min, max, s:integer; proizvedenie:real; beginwriteln ('Введите n чисел') ; for b:=1 to n do read (a[b]) ; for b:=1 to n do write (a[b],' ') ; min:=a[1]; max:=0; for b:=1 to n do begin if a[b]>max then max:=a[b]; if a[b]Комментировать
  2. Жалоба
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дается последовательность из N чисел. Выведите разницу между максимальным и минимальным элементами последовательности. Формат входных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача A Дана последовательность чисел А длины N. Требуется вывести в обратном порядке. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 1000000) - длину последовательности.
Ответы (1)
Дается последовательность из N чисел. Выведите результат произведения максимального и минимального элементов последовательности. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 100000).
Ответы (1)
Задача D Нечет Задано два целых числа A и B. Найдите сумму нечетных чисел от A до B. Формат входных данных Первая строка входного файла содержит два целых числа A и B (1 < = A, B < = 10^9). Формат выходных данных Выведите ответ к задаче.
Ответы (1)
задается целое число N. нужно вывести количество четных делителей числа N. Формат входных данных Единственная строка входного файла содержит единственное целое число N (1
Ответы (1)
Задача C. Делители Дано целое число N. Вам нужно определить количество его делителей Формат входных данных Единственная строка входного файла содержит целое число N (1 < = N < = 10^12) Формат выходных данных Выведите ответ к задаче
Ответы (1)
Помогите с ответом
Помогите решить - теплоход за два дня был в пути 12 часов. В первый день он прошел 256 км., а во второй - 128 км. Сколько часов теплоход провел в пути в каждый из этих дней, если он двигался с одинаковой скоростью?
Нет ответа
на каждой из вещей - куртке; пальтои шубе-пришито 3; 4 6 пуговиц на пальто4 пуговицы на куртке пуговиц больше чем на пальто сколько пуговиц на куртке и сколько на шубе?
Нет ответа
Упростите выражения: 1) - 36+m+24 2) n+42-13 3) 5,7-7,7+a 4) - 0,44+x-0,22 5) 3/8-0,375+k 6) m+5/9-2/3
Нет ответа
решите уравнения: 8/9*3 целых 3/5 * (-2,1 х) = 20,16
Нет ответа
Ребят, как определять валентность?!
Нет ответа