Задать вопрос
18 сентября, 09:07

Задано четырехзначное натуральное число X. Получить из него число, записанное теми же цифрами, но в обратном порядке, а так же сумму исходного и полученного числа.

+4
Ответы (1)
  1. 18 сентября, 09:45
    0
    C#:

    for (int i = n; i > = 1; i--)

    {

    Console. WriteLine (i + ",") ;

    }

    pascal, еле перевел ...

    uses crt;

    var num, conv, i : integer;

    begin write ('Введите четырехзначное число : ') ;

    readln (num) ;

    conv : = 0;

    while (num >0) do

    begin

    i : = num mod 10;

    conv : = conv*10 + i;

    num : = num div 10;

    end;

    writeln ('Число задом наперед : D: ', conv) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задано четырехзначное натуральное число X. Получить из него число, записанное теми же цифрами, но в обратном порядке, а так же сумму ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
Дано натуральное число. Записать число, записанное теми же цифрами, но в обратном порядке. Подсказка последовательно отделяемое каждую цифру, потом ее значение прибавляем к переменной s, умноженной на 10.
Ответы (1)
Написать программу на паскале. Дано двузначное число. Получить число, записанное теми же цифрами в обратном порядке.
Ответы (1)
Написать в Турбо Паскале программу: Задано 3-х значное число X. Найти разность между этим числом и числом, записанным теми же цифрами, но в другом порядке. (Видимо в обратном порядке?)
Ответы (1)
1. Дано натуральное число n. Переставить его цифры так, чтобы образовалось максимальное число, записанное теми же цифрами. 2. Найти все двузначные числа, сумма квадратов которых делится на 17. Всё это нужно сделать в программе Паскаль, но КАК?!
Ответы (1)