Задать вопрос
9 июня, 21:58

Дано натуральное число. Записать число, записанное теми же цифрами, но в обратном порядке. Подсказка последовательно отделяемое каждую цифру, потом ее значение прибавляем к переменной s, умноженной на 10.

+5
Ответы (1)
  1. 10 июня, 00:25
    0
    Pascal ABC

    program perevod;

    uses crt;

    var

    a, i, error:integer;

    s, d:string;

    begin

    write ('Введите число: ') ;

    readln (a) ;

    str (a, s) ;

    for i:=1 to length (s) do d:=s[i]+d;

    val (d, a, error) ;

    write ('Ответ: ', a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число. Записать число, записанное теми же цифрами, но в обратном порядке. Подсказка последовательно отделяемое каждую ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Запишите на алгоритмическом языке алгоритм, в результате которого переменной A будет присвоено значение переменной B, переменной B-значение переменной C, а переменной C-значение переменной A. Используйте не более одной промежуточной переменной.
Ответы (1)
Задано четырехзначное натуральное число X. Получить из него число, записанное теми же цифрами, но в обратном порядке, а так же сумму исходного и полученного числа.
Ответы (1)
Написать программу на паскале. Дано двузначное число. Получить число, записанное теми же цифрами в обратном порядке.
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)