Задать вопрос
9 марта, 08:37

1. Дано натуральное число n. Переставить его цифры так, чтобы образовалось максимальное число, записанное теми же цифрами.

2. Найти все двузначные числа, сумма квадратов которых делится на 17.

Всё это нужно сделать в программе Паскаль, но КАК?!

+2
Ответы (1)
  1. 9 марта, 11:09
    0
    1. uses crt;

    const m=8;

    var n, i, b, c, p, k:integer;

    a:array[1 ... m] of integer;

    begin

    readln (n) ;

    b:=n;

    k:=1;

    repeat

    c:=b mod 10;

    a[k]:=c;

    b:=b div 10;

    inc (k) ;

    until b=0;

    repeat

    p:=0;

    for i:=1 to k-1 do

    if a[i]
    begin

    p:=1;

    a[i]:=a[i]+a[i+1];

    a[i+1]:=a[i]-a[i+1];

    a[i]:=a[i]-a[i+1];

    end;

    until p=0;

    for i:=1 to k-1 do

    write (a[i]) ;

    end.

    2. uses crt;

    const n=99;

    var i, j:integer;

    begin

    for i:=10 to n do

    for j:=10 to n do

    if ((i*i+j*j) mod 17=0) then write (i,' ', j,' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дано натуральное число n. Переставить его цифры так, чтобы образовалось максимальное число, записанное теми же цифрами. 2. Найти все ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
написать программу на языке паскаль, которая считывает с клавиатуры строку S, состоящую из цифр. В заданном строкой S натуральном N-разрядном числе упорядочить цифры так, чтобы получить наибольшее число, записанное теми же цифрами.
Ответы (1)
Решить по программе Паскаль. Найти все двузначные числа, сумма квадратов цифр которых кратна M.
Ответы (1)