Задать вопрос
22 мая, 03:14

написать программу на языке паскаль, которая считывает с клавиатуры строку S, состоящую из цифр. В заданном строкой S натуральном N-разрядном числе упорядочить цифры так, чтобы получить наибольшее число, записанное теми же цифрами. Строка S не пустая и содержит не более 200 символов. Строка S состоит только из цифр.

+3
Ответы (1)
  1. 22 мая, 04:31
    0
    S, a, d:string;

    i, n, j, b:integer;

    c:array[1 ... 200] of integer;

    begin

    readln (s) ;

    readln (n) ;

    a:=copy (s, 1, n) ;

    for i:=1 to n do

    val (a[i], c[i]) ;

    for i:=1 to n do

    for j:=1 to n do

    if c[i]
    b:=c[i]; c[i]:=c[j]; c[j]:=b; end;

    for i:=1 to n do

    str (c[i], d[i]) ;

    s:=d;

    writeln (s) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «написать программу на языке паскаль, которая считывает с клавиатуры строку S, состоящую из цифр. В заданном строкой S натуральном ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая считывает с клавиатуры строку S и определяет, встречаются ли в строке S слова палиндромы. Словом считается последовательность символов, ограниченная проьелами, и не имеющая пробелов внутри себя.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
С клавиатуры вводят строку, состоящую из латинских букв и цифр. Написать программу, которая вычисляет сумму цифр, попадающихся в этой строке, а также выводящую строку после исключения из неё этих цифр. Для паскаль abc.
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Вам дана строка S. Надо определить, сколько в ней цифр Формат входных данных Единственная строка входного файла содержит строку S, которая может состоять из букв английского алфавита и цифр.
Ответы (2)