Задать вопрос
18 августа, 03:12

Напишите программу, которая считывает с клавиатуры строку S и определяет, встречаются ли в строке S слова палиндромы. Словом считается последовательность символов, ограниченная проьелами, и не имеющая пробелов внутри себя. Строка S не пустая, содержит не более 200 символов и состоит только из строчных и прописных букв латинского алфавита и пробелов

+5
Ответы (1)
  1. 18 августа, 05:31
    0
    Var

    s, t:string;

    n, i:integer;

    begin

    write ('Введите строку: ') ;

    readln (t) ;

    n:=1;

    t:=t+' ';

    for i:=2 to length (t) do

    if ((t[i]=' ') or (i=length (t))) and (i-n>1) then

    begin

    s:=Copy (t, n, i-n) ;

    if s=ReverseString (s) then

    begin

    writeln ('Да, палиндромы есть') ;

    halt

    end

    else n:=i+1

    end;

    writeln ('Палиндромов нет')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая считывает с клавиатуры строку S и определяет, встречаются ли в строке S слова палиндромы. Словом считается ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
Задача по программированию на Паскаль, нужна помощь. Дана строка состоящая из строчных букв английского алфавита. Необходимо определить какие буквы встречаются в этой строке больше одного раза.
Ответы (1)
Дана строка S, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в S ровно один раз. Формат входных данных Во входном файле дана строка S.
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)
Вася передает Пете сообщение, состоящее только из символов (заглавных и строчных) латинского алфавита, пробелов и знаков препинания (.,!?) за 2 минуты. Сообщение состоит из 200 символов. Какова скорость передачи информации (бит в секунду) ?
Ответы (2)