Задать вопрос
16 декабря, 11:21

Индивидуальное зачетное задание

Напишите программу, запрашивающую у пользователя время и сообщающую угол поворота минутной и часовой стрелки в градусах и радианах (помните, что тригонометрические функции в Паскале работают с радианами)

+3
Ответы (1)
  1. 16 декабря, 14:34
    0
    Var

    n, m:integer;

    r1, r2:real;

    begin

    writeln ('Введите количество часов: ') ;

    readln (n) ;

    writeln ('Введите количество минут: ') ;

    readln (m) ;

    n:=n mod 12;

    r2:=m/60*360;

    r1: = (n*360+r2) / 12;

    writeln ('Угол поворота часовой стрелки ', r1,' градусов или ', r1/180*Pi,' радиан') ;

    writeln ('Угол поворота минутной стрелки ', r2,' градусов или ', r2/180*Pi,' радиан') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Индивидуальное зачетное задание Напишите программу, запрашивающую у пользователя время и сообщающую угол поворота минутной и часовой ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль! 1. Напишите программу, запрашивающую у пользователя два момента времени (количество часов, минут и секунд) и сообщающую число секунд, прошедшее между этими двумя моментами. 2. Ввести два числа.
Ответы (1)
1) Разработайте программу, запрашивающую у пользователя длины обеих катетов прямоугольного треугольника, и выводящую на экран гипотезу по формуле Пифагора 2) Запросите у пользователя длину ребра куба, Найдите и выведите на экран площадь одной грани,
Ответы (1)
Написать программу на языке Паскаль. 1. Написать программу из 3 введенных значений. Найти максимальное 2. Написать программу запрашивающую номер класса и выводящееся сообщения если 1-4 класса-младшая школа, 5-9-средняя, 10-11-старшая 3.
Ответы (1)
Написать программу на паскале, запрашивающую возраст пользователя, если ему не менее 18 лет сообщите ему что он имеет право голосовать, в противном случае вычислите через сколько лет ему предоставят это право.
Ответы (1)
Написать программу на паскале, запрашивающую у пользователя его возраст и в зависимости от введенного возраста выводящую, например, грудничок, детсадовец, школьник, студент, работающий, пенсионер
Ответы (1)