Задать вопрос
31 мая, 09:34

Паскаль!

1. Напишите программу, запрашивающую у

пользователя два момента времени (количество часов, минут и секунд) и

сообщающую число секунд, прошедшее между этими двумя моментами.

2. Ввести

два числа. Если сумма этих чисел четная, найти произведение, в противном

случае, найти частное этих чисел.

3. Одноклеточная

амёба каждые 3 часа делится на 2 клетки. Определить, сколько будет амёб через

3,6,9,12, ...24 часа.

4. Дан одномерный массив А (i), i = 7, заданный случайным образом.

Вывести на экран массив, значения которого находятся в диапазоне [0; 10]

+4
Ответы (1)
  1. 31 мая, 10:42
    0
    1) var a, b, c, a1, b1, c1, s:integer;

    begin

    writeln ('Введите количество часов в первом моменте времени') ;

    readln (a) ;

    writeln ('Введите количество минут в первом моменте времени') ;

    readln (b) ;

    writeln ('Введите количество секунд в первом моменте времени') ;

    readln (c) ;

    writeln ('Введите количество часов во втором моменте времени') ;

    readln (a1) ;

    writeln ('Введите количество минут во втором моменте времени') ;

    readln (b1) ;

    writeln ('Введите количество секунд во втором моменте времени') ;

    readln (c1) ;

    s:=abs (a*3600+b*60+c-a1*3600-b1*60-c1) ;

    writeln (s,' секунд') ;

    end.

    2) var a, b:integer;

    s:real;

    begin

    writeln ('Введите первое число') ;

    readln (a) ;

    writeln ('Введите второе число') ;

    readln (b) ;

    if (a+b) mod 2 = 0 then s:=a*b

    else s: = a/b;

    writeln (s) ;

    end.

    3) var b, s, n:real;

    begin

    writeln ('Введите количество часов') ;

    readln (n) ;

    n:=n/3;

    s:=2*power (2, (n-1)) ;

    writeln (s,' амёб') ;

    end.

    4) var a:array[1 ... 7]of integer;

    i:integer;

    begin

    for i:=1 to 7 do

    begin

    a[i]:=random (11) ;

    writeln ('a[', i,'] = ', a[i]) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль! 1. Напишите программу, запрашивающую у пользователя два момента времени (количество часов, минут и секунд) и сообщающую число ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Разработайте программу, которая просит пользователя ввести с клавиатуры 2 числа. Если сумма чисел четная, следует 2-ое число разделить на 1-ое и вывести результат на экран, если сумма чисел не четная, следует 1-ое число умножить на второе и вывести
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
Дан массив из N элементов (12 элементов), заданный случайным образом от - 10 до 10. Вывести на экран этот массив. С клавиатуры вводятся два числа меньше N. Вывести на экран часть массива входящих в диапазон, двух введенных чисел.
Ответы (1)
Дан одномерный целочисленный массив K из 15 элементов, заданный случайным образом в диапазоне от - 20, до + 25. Найдите сумму всех положительных элементов, индексы которых кратны 3. Вывести на экран сам массив и сумму.
Ответы (2)