Задать вопрос
20 января, 04:25

Дан одномерный целочисленный массив K из 15 элементов, заданный случайным образом в диапазоне от - 20, до + 25.

Найдите сумму всех положительных элементов, индексы которых кратны 3. Вывести на экран сам массив и сумму.

+3
Ответы (2)
  1. 20 января, 05:57
    0
    Var K:array [1 ... 15] of integer;

    z:integer;

    begin

    for i:=1 to 15 do

    k: = random (56) - 20;

    z:=0;

    for i:=1 to 15 do

    if k[i]>0 then z:=z+k[i];

    for i:=1 to 15 do

    writeln (z) ;

    end.

    Начало и доп знаки доставь
  2. 20 января, 06:03
    0
    Program z1; const n = 15; Var k: array [1 ... n] of integer; i, s:integer; Begin randomize; for i:=1 to n do begin k[i]:=random (25) - 20; write (k[i],' ') ; end; s:=0; for i:=1 to n do if ((k[i]>0) and (i mod 3 = 0)) then s:=s+k[i]; writeln; writeln ('Сумма элементов - ', s) ; End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан одномерный целочисленный массив K из 15 элементов, заданный случайным образом в диапазоне от - 20, до + 25. Найдите сумму всех ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
Дан массив из N элементов (12 элементов), заданный случайным образом от - 10 до 10. Вывести на экран этот массив. С клавиатуры вводятся два числа меньше N. Вывести на экран часть массива входящих в диапазон, двух введенных чисел.
Ответы (1)