Задать вопрос
19 мая, 16:12

Дан массив из N элементов (12 элементов), заданный случайным образом от - 10 до 10. Вывести на экран этот массив. С клавиатуры вводятся два числа меньше N. Вывести на экран часть массива входящих в диапазон, двух введенных чисел. Эти два числа будут индексами к тем числам, которые надо вывести.

+5
Ответы (1)
  1. 19 мая, 18:26
    0
    Const n = 12;

    var a:array [1 ... n] of integer;

    i, c, b:integer;

    begin

    randomize;

    for i:=1 to n do

    begin

    a[i]:=random (21) - 10;

    write (a[i],' ') ;

    end;

    writeln;

    repeat

    write ('C = ') ;

    readln (c) ;

    until c in [1 ... n];

    repeat

    write ('B = ') ;

    readln (b) ;

    until b in [1 ... n];

    if c
    for i:=c to b do write (a[i],' ')

    else for i:=b to c do write (a[i],' ') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из N элементов (12 элементов), заданный случайным образом от - 10 до 10. Вывести на экран этот массив. С клавиатуры вводятся два ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (2)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)