Задать вопрос
7 декабря, 01:48

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0; 20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

+2
Ответы (2)
  1. 7 декабря, 04:35
    0
    1. const N=10;

    type Vector = array [1 ... N] of integer;

    var B: vector;

    max : integer;

    procedure IntVector (N: integer; var a: vector) ;

    begin

    for var i : = 1 to N do a[i] : = random (100) ;

    end;

    procedure OutVector (N: integer; a: vector) ;

    begin for var i : = 1 to N do

    begin write (a[i]:5) ;

    end;

    end;

    procedure Srav (a:vector; N, g:integer) ;

    begin

    g : = a[1];

    for var i:=1 to N do

    if (g < a[i]) then g:=a[i];

    writeln (g) ;

    end;

    Begin

    IntVector (N, B) ;

    writeln;

    OutVector (N, B) ;

    writeln;

    Srav (B, N, max) ;

    writeln;

    End.

    2. const N = 10;

    type Vector = array [1 ... N] of integer;

    var B: vector;

    r, v : real;

    procedure IntVector (N: integer; var a: vector) ;

    begin

    for var i : = 1 to N do

    a[i] : = random (20) ;

    end;

    procedure OutVector (N: integer; a: vector) ;

    begin

    for var i : = 1 to N do

    begin

    write (a[i]:5) ;

    end;

    end;

    function srednee (a: vector; N: integer) : real;

    begin

    for var i : = 1 to N do begin result : = (result + a[i]) ;

    end;

    end;

    function kolvo (a: vector; g: real) : real;

    begin

    for var i : = 1 to N do

    if (a[i] < (srednee (a, N) / 10)) then result : = result + 1;

    end;

    begin

    IntVector (N, B) ; writeln;

    OutVector (N, B) ;

    writeln;

    writeln ((srednee (B, N) / 10) : 5:3) ; r : = kolvo (B, v) ;

    writeln (r) ;

    end.
  2. 7 декабря, 04:46
    0
    1)

    constn=10;

    var

    i:byte;

    max:real;

    a:array[1 ... n] of real;

    begin

    for i:=1 to n do

    a[i]:=random (100) ;

    for i:=1 to n do

    write (a[i]:3) ;

    for i:=1 to n do

    max:=a[i];

    if max
    writeln ('Максимальный элемент = ', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
создать массив а из десяти целых чисел, принадлежащих промежутку [0; 20). вывести полученный массив на экран. вычислить количество элементов массива, значения которых превышают средне арифметическое значений его элементов
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)