Задать вопрос
30 декабря, 04:51

создать массив а из десяти целых чисел, принадлежащих промежутку [0; 20). вывести полученный массив на экран. вычислить количество элементов массива, значения которых превышают средне арифметическое значений его элементов

+3
Ответы (1)
  1. 30 декабря, 08:26
    0
    Var a:array[1 ... 10] of integer; i, k:integer; q:real;

    begin

    for i:=1 to 10 do begin

    a[i]:=random (20) ;

    writeln (a[i]) ;

    q:=q+a[i];

    end;

    q:=q/10;

    for i:=1 to 10 do

    if a[i]>q then inc (k) ;

    writeln ('Чисел превышающих среднее: ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «создать массив а из десяти целых чисел, принадлежащих промежутку [0; 20). вывести полученный массив на экран. вычислить количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Создать массив из 20-ти случайных чисел (значения от 0 до 100). Вывести на экран значения массива строкой. Вычислить сумму элементов массива! 2. Создать массив из 20-ти случайных чисел (значения от 0 до 100).
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (2)
1) Составить массив из 10 целых чисел, вывести его на экран и подсчитать количество элементов массива, значения которых не превышают трех 2) Составить массив из 10 целых чисел и вывести его на экран, подсчитать сумму отрицательных и положительных
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)