Задать вопрос
19 мая, 16:18

Работаем в Pascal ABC

1. Найти количество цифр меньше 6 в целом x.

Тест: 254904 - 5

2. Найти сумму первой и последней цифры в целом x.

Тест: 254904 - 6

3. Найти сумму самой большой и самой маленькой цифры в целом x

Тест: 254904 - 9

+1
Ответы (1)
  1. 19 мая, 17:14
    0
    1.

    var x, s:integer;

    begin

    read (x) ;

    s : = 0;

    while x > 0 do

    begin

    if x mod 10 < 6 then s : = s + 1; {здесь была ошибка}

    x : = x div 10

    end;

    write (s)

    end.

    2.

    var x, s:integer;

    begin

    read (x) ;

    s : = x mod 10;

    while x > 10 do

    x : = x div 10;

    write (x + s)

    end.

    3.

    var x, a, b:integer;

    begin

    read (x) ;

    a : = x mod 10;

    b : = x mod 10;

    while x > 0 do

    begin

    if x mod 10 > a then a : = x mod 10;

    if x mod 10 < b then b : = x mod 10;

    x : = x div 10;

    end;

    write (a + b)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Работаем в Pascal ABC 1. Найти количество цифр меньше 6 в целом x. Тест: 254904 - 5 2. Найти сумму первой и последней цифры в целом x. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)