Задать вопрос
21 августа, 22:22

Составьте программу к задаче: Возвести данное число в куб, если оно чётное, и увеличить на 3, если оно-нечётное

PS: Pascal

+4
Ответы (2)
  1. 21 августа, 23:05
    0
    var

    a: integer;

    begin

    writeln ('Введите число: ') ;

    read (a) ;

    if a mod 2 0 then writeln ('Число нечетное: ', a+3)

    else writeln ('Число четное: ', a*a*a) ;

    end.
  2. 22 августа, 01:11
    0
    Uses crt;

    var i:integer;

    begin

    readln (i) ;

    if i mod 2=0 then writeln (power (i, 3))

    else writeln (i+3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу к задаче: Возвести данное число в куб, если оно чётное, и увеличить на 3, если оно-нечётное PS: Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу в паскале Ввести число. Если оно четное и положительное, разделить его на 4, если четное и отрицательное - умножить на 5, если нечетное - возвести в квадрат.
Ответы (1)
Имеется исполнитель "Двоечка", имеющий следующую последовательность команд: 1. Удваивает данное число. 2. Прибавляет к данному числу 2, если данное число четное и вычитает из данного числа 2, если данное число нечетное. 3.
Ответы (1)
Напишите программу для Паскаля. Возвести чётное число в квадрат, а нечётное в куб.
Ответы (1)
даны числа 400, 121, 93,80, 4. прочитай правила и запиши на каждом листке. если число нечётное то его записывают на листке с подписью дик если число нечётное и трехзначное то его записывают на листке с подписью ник если число четное или трехзначное
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)