Задать вопрос
29 апреля, 04:43

Составить программу в паскале

Ввести число. Если оно четное и положительное, разделить его на 4, если четное и отрицательное - умножить на 5, если нечетное - возвести в квадрат.

+1
Ответы (1)
  1. 29 апреля, 08:20
    0
    Var n:longint;

    c:real;

    begin

    write ('N = ') ;

    readln (n) ;

    if (n mod 2 = 0) and (n>0) then c:=n/4 else

    if (n mod 2 = 0) and (n<0) then c:=n*5 else

    if (n mod = 1) then c:=sqr (n) ;

    write (c:0:2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в паскале Ввести число. Если оно четное и положительное, разделить его на 4, если четное и отрицательное - умножить на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Программа на языке паскаль. ввести с клавиатуры целое число, если оно положительное возвести его в квадрат, если отрицательное возвести в четвёртую степень. Напечатать результат на экране
Ответы (1)
Помогите с задачей C#! Ввести одномерный массив, вывести его. Выяснить, какое число в массиве встретится ранее - положительное или отрицательное (нули не рассматривать).
Ответы (1)
Ввести число. Если оно положительное, возвести его в квадрат, иначе возвести его в куб
Ответы (1)
Помогите написать в паскале! Ввести три целых числа x, y, z. Если хотя бы одно из них четное, то первому четному числу присвоить значение произведения этих чисел.
Ответы (1)