Задать вопрос
23 августа, 19:13

Напишите программу для Паскаля.

Возвести чётное число в квадрат, а нечётное в куб.

+4
Ответы (1)
  1. 23 августа, 20:04
    0
    Var

    x, rez:integer;

    begin

    readln (x) ;

    if x mod 2 = 0 then

    rez:=x*x

    else

    rez:=x*x*x;

    writeln (x) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу для Паскаля. Возвести чётное число в квадрат, а нечётное в куб. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу в паскале Ввести число. Если оно четное и положительное, разделить его на 4, если четное и отрицательное - умножить на 5, если нечетное - возвести в квадрат.
Ответы (1)
Составьте программу к задаче: Возвести данное число в куб, если оно чётное, и увеличить на 3, если оно-нечётное PS: Pascal
Ответы (2)
Напишите программы, для Паскаля. 1. Дано число Х. Определить положительное число или отрицательное. 2. Даны три целых числа. Определить количество положительных чисел. 3. Дано число Х. Определить чётное число или нечётное.
Ответы (2)
Помогите написать в паскале! Ввести три целых числа x, y, z. Если хотя бы одно из них четное, то первому четному числу присвоить значение произведения этих чисел.
Ответы (1)
Число 712 возвести в двоичную систему счисления и обратно число 712 возвести в восьмеричную систему счисления и обратно число 712 возвести в шестнадцатеричную систему счисления
Ответы (1)