Задать вопрос
4 ноября, 04:35

Составьте программу, которая запрашивает имя (один из символов: 'а' - Алексей, 'с' - Сергей, 'м' - Михаил, 'к' - Константин) и отчество ('б' - Борисович или 'с' - Сергеевич) и выдаёт их полное название.

Протокол:

Введите имя и отчество: сс

Вас зовут Сергей Сергеевич

+5
Ответы (1)
  1. 4 ноября, 06:13
    0
    Когда запустишь программу, не забудь переключиться на русский язык

    var s:string;

    begin

    writeln ('Введите имя и отчество: ') ;

    readln (s) ;

    write ('Вас зовут ') ;

    case s[1] of

    'а': write ('Алексей ') ;

    'с': write ('Сергей ') ;

    'м': write ('Михаил ') ;

    'к': write ('Константин ') ;

    end;

    case s[2] of

    'б': write ('Борисович') ;

    'с': write ('Сергеевич') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая запрашивает имя (один из символов: 'а' - Алексей, 'с' - Сергей, 'м' - Михаил, 'к' - Константин) и отчество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите сделать программу в Паскале В котором 1) Программа выдает сообщение "Вы маль или дево" 2) Пользователь в переменную ST1 задает значение маль или дево 3) Программа выдает сооб "Ты пошла бы играть в куклы" 4) Вводить ответ через переменную
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Составить программу - конвертер, которая запрашивает тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, а также число - значение в этой единице измерения времени и переводит данное число во все остальные единицы измерения
Ответы (1)
Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию.
Ответы (1)
Составить программу - калькулятор, которая запрашивает тип математической функции: 1-квадрат, 2-куб, 3 - корень квадратный, 4 - обратная функция, а также аргумент функции x и вычисляет для x соответствующую математическую функцию.
Ответы (1)