Задать вопрос
22 июля, 22:05

Известны координаты точки, вывести сообщение какой координатной четверти она принадлежит. Рассмотреть случай начала координат и рассмотреть случай, когда она принадлежит оси x.

+5
Ответы (1)
  1. 22 июля, 23:36
    0
    Program gt;

    var x, y:integer;

    begin

    read (x, y) ;

    if (x>0) and (y>0) then writeln ('первая четверт') ;

    if (x0) then writeln ('вторая четверт') ;

    if (x<0) and (y<0) then writeln ('третья четверт') ;

    if (x>0) and (y<0) then writeln ('четвертая четверть') ;

    if (x=0) and (y=0) then writeln ('начала координат') ;

    if (x=0) or (y=0) then writeln ('точка находится на начале координат') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Известны координаты точки, вывести сообщение какой координатной четверти она принадлежит. Рассмотреть случай начала координат и рассмотреть ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны координаты двух точек на плоскости, требуется определить, лежат ли они в одной координатной четверти или нет. (На Паскале) Входные данные Вводятся 4 числа: координаты первой точки (x1, y1) и координаты второй точки (x2, y2).
Ответы (1)
Даны целочисленные координаты X и Y. Написать программу, которая выводит на экран сообщение "Принадлежит" или "Не принадлежит" эта точка 1-ой четверти координатной плоскости. Точки на осях координат считаются принадлежащими к данной четверти.
Ответы (1)
Задача pascal Даны целочисленные координаты точки на плоскости. Если точка совпадает с началом координат, то вывести 0. Если точка не совпадает с началом координат, но лежит на оси ОХ или OY, то вывести соответственно 1 или 2.
Ответы (1)
Определить, какой четверти координатной плоскости, оси Х, оси У или началам координат принадлежит точка с координатами, заданными случайным образом. Pascal ABC
Ответы (1)
С клавиатуры вводятся пары вещественных чисел - координаты x и y точек на плоскости. Координаты 0,0 служат для окончания ввода. Вывести на экран координаты точки, находящейся на максимальном расстоянии от начала координат.
Ответы (2)