Задать вопрос
7 декабря, 21:33

С клавиатуры вводятся пары вещественных чисел - координаты x и y точек на плоскости. Координаты 0,0 служат для окончания ввода.

Вывести на экран координаты точки, находящейся на максимальном расстоянии от начала координат.

PascalABC

функцией или процедурой

+5
Ответы (2)
  1. 7 декабря, 21:49
    0
    Var X, Y, Xm, Ym:real;

    Procedure ABC () ;

    Begin

    Repeat

    Write ('x = ') ; ReadLn (x) ;

    Write ('y = ') ; ReadLn (y) ;

    if (x*x+y*y) > (Xm*Xm+Ym*Ym) then

    Begin

    Xm:=x;

    Ym:=y

    End

    Until (X = 0) and (Y = 0)

    End;

    Begin

    Xm:=0;

    Ym:=0;

    ABC;

    WriteLn (' (', Xm,',', Ym,') ')

    End.
  2. 7 декабря, 22:00
    0
    Var

    a, b, c, d:integer;

    e, v, s, h:string;

    begin

    h:='va ';

    v:='raine';

    readln (a, b) ;

    s:='Sla';

    if (a<0) then

    a=abs (a) ;

    if (b<0) then

    b:=abs (b) ;

    e:='Uk';

    writeln (s+h+v+e) ;

    end;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводятся пары вещественных чисел - координаты x и y точек на плоскости. Координаты 0,0 служат для окончания ввода. Вывести на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3. 2. Прочитать с клавиатуры число n и вывести на экран сумму его четных цифр 3.
Ответы (1)