Задать вопрос
22 июля, 20:02

Помогите составить программу по паскалю!

Определить количество чисел с цифрой 4 в записи числа

+4
Ответы (1)
  1. 22 июля, 21:43
    0
    Var

    ar:array[1 ... 2000] of integer;

    n, i, count:integer;

    begin

    readln (n) ;

    for i:=1 to n do begin

    read (ar[i]) ;

    while ((ar[i]>0) and ((ar[i] mod 10) 4)) do ar[i]:=ar[i] div 10;

    if ar[i] mod 10 = 4 then inc (count) ;

    end;

    writeln (count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите составить программу по паскалю! Определить количество чисел с цифрой 4 в записи числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу по выдаче рандомных чисел, содержащих от 1 до 5 знаков, состоящих из чисел от 1 до 12, так чтобы: За цифрой 1 могли следовать только цифры 4, 5, 7, 9, 10 За цифрой 2 - только 5, 6, 8, 10, 11 За цифрой 3 - только 6, 7, 9, 11, 12 За
Ответы (1)
Надо составить программу по паскалю) составить программу проверяющую утверждения, что сумма цифр введенного вами числа делится на 5.
Ответы (1)
Составить программу, которая в последовательности целых чисел находит сумму чисел кратных 7 в диапозоне от 6 до 80. Программа получает на вход целые числа, кол-во не известно, 0-признак окончания Входные данные: - 7,14,84,0 Составить по Паскалю
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Сколько единиц в двоичной записи числа 67,5? 2) Сколько единиц в двоичной записи числа 23,375? 3) Сколько значащих нулей в двоичной записи числа 19,125? 4) Сколько значащих нулей в двоичной записи числа 37,875?
Ответы (1)