Задать вопрос
29 июля, 20:38

Составить программу, которая в последовательности целых чисел находит сумму чисел кратных 7 в диапозоне от 6 до 80. Программа получает на вход целые числа, кол-во не известно, 0-признак окончания

Входные данные: - 7,14,84,0

Составить по Паскалю

+2
Ответы (1)
  1. 29 июля, 23:20
    0
    programm p;

    var

    a:array[1 ... 100 ] of integer;

    i, n:integer;

    s:integer;

    begin

    readln n;

    for i:=1 to n do

    readln (a[i]) ;

    s:=0;

    for i:=1 to n do

    begin

    if (a[i]>5) and (a[i]<81) and (a[i]/7=int a[i]/7) then

    s:=s+a[i];

    if a[i] = 0 then break;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая в последовательности целых чисел находит сумму чисел кратных 7 в диапозоне от 6 до 80. Программа получает на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)